Текущее время: 16 янв 2021, 08:11

Часовой пояс: UTC + 3 часа




Начать новую тему Ответить на тему  [ Сообщений: 8 ] 
Автор Сообщение
 Заголовок сообщения: Трекер на базе MikroTik LtAP
СообщениеДобавлено: 19 сен 2020, 13:00 
Не в сети

Зарегистрирован: 22 мар 2018, 23:41
Сообщений: 8
Доброго времени суток.

Сам трекер по докладу подключил, поправив в нём некоторые моменты.

Возник вопрос:
где можно посмотреть полный список параметров для данного типа интеграции?

Перечень переменных, которые отправляются в скрипте
Код:
imei
lat
lon
timestamp
hdop
altitude
speed
bearing
batt
temp
sim
button

В скрипте MikroTik ещё доступны значения для sats (количество спутников - в интерфейсе платформы видел) и gpsValid (корректность данных - в интерфейсе не видел).

Спасибо.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Трекер на базе MikroTik LtAP
СообщениеДобавлено: 19 сен 2020, 14:07 
Не в сети

Зарегистрирован: 22 мар 2018, 23:41
Сообщений: 8
(Не успели дополнить прошлое сообщение)
Тут ничего полезного тоже не нашли:
https://livegpstracks.com/default.php?c ... &modid=640

Да и хорошо бы ссылку на сам доклад с кодом оставить:
https://mum.mikrotik.com/presentations/ ... 101308.pdf


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Трекер на базе MikroTik LtAP
СообщениеДобавлено: 22 сен 2020, 11:34 
Не в сети
Support Live GPS
Аватар пользователя

Зарегистрирован: 25 сен 2012, 08:43
Сообщений: 2706
larisado писал(а):
где можно посмотреть полный список параметров для данного типа интеграции?

Вы весь список и перечислили.
Скрипт подключения реализовался в контакте с докладчиком. Больше пожеланий по параметрам не было, соответственно, только это и реализовано.


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Трекер на базе MikroTik LtAP
СообщениеДобавлено: 28 сен 2020, 00:15 
Не в сети

Зарегистрирован: 22 мар 2018, 23:41
Сообщений: 8
livegps писал(а):
larisado писал(а):
где можно посмотреть полный список параметров для данного типа интеграции?

Вы весь список и перечислили.
Скрипт подключения реализовался в контакте с докладчиком. Больше пожеланий по параметрам не было, соответственно, только это и реализовано.

Понятно, спасибо.

Просто увидели у вас в интерфейсе параметр, который доступен в трекере, но не передаётся в примере.
Тем более, что, скорее всего, проверяете необязательные параметры на isset()/!empty(), потому решили уточнить, вдруг он, всё-таки, есть, просто не описан :)

Ссылку на gist с исправленным скриптом можно тут опубликовать?
Я бы его и на форуме опубликовал, только не нашёл тег спойлера (только код).


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Трекер на базе MikroTik LtAP
СообщениеДобавлено: 13 окт 2020, 20:07 
Не в сети
Support Live GPS
Аватар пользователя

Зарегистрирован: 25 сен 2012, 08:43
Сообщений: 2706
larisado писал(а):
Ссылку на gist с исправленным скриптом можно тут опубликовать?

Да, конечно.

larisado писал(а):
Я бы его и на форуме опубликовал, только не нашёл тег спойлера (только код).

Теги для спойлера:
Спойлер
Код:
[spoiler=Спойлер]TEXT[/spoiler]


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Трекер на базе MikroTik LtAP
СообщениеДобавлено: 19 ноя 2020, 03:55 
Не в сети

Зарегистрирован: 22 мар 2018, 23:41
Сообщений: 8
@livegps Спасибо.

Выложил чуть переработанный рабочий код из презентации на гитхаб.

В начале скрипта замените "YOUR_IMEI" на "IMEI", который будете использовать с LiveGPS.

Код под спойлером
Код:
# set your IMEI here
:local fakeImei "YOUR_IMEI"
:global isDebug
:set $isDebug "off"
# $isDebug values:
# "logging" - log to system log
# "terminal" - log to terminal
# "off" - none output

:local serverURL "http://livegpstracks.com/mikrotik.php"

:local gpsDateTime
:local lat
:local lon
:local alt
:local gpsSpeed
:local bearing
:local gpsValid
:local sats
:local hdop
:local DateTime
:local outputURL

#Check and set coordinate format and get data from GPS
:if ( [/system gps get coordinate-format ] != "dd") do={/system gps set coordinate-format=dd}

/system gps monitor once do={
:set $gpsDateTime $("date-and-time")
:set $lat [:pick $latitude 0 7]
:set $lon [:pick $longitude 0 8]
:set $alt $("altitude")
:set $gpsSpeed $("speed")
:set $bearing $("true-bearing")
:set $gpsValid $("valid")
:set $sats $("satellites")
:set $hdop $("horizontal-dilution")
}

# Strip post comma value from speed, altitude and bearing
:set $alt [:pick $alt 0 [:find $alt "."]]
:set $gpsSpeed ([:pick $gpsSpeed 0 [:find $gpsSpeed "."]].".0")
:set $bearing ([:pick $bearing 0 [:find $bearing "."]].".0")
# Reformat Date-Time
:local symPos
:set $symPos [:find $gpsDateTime " "]
:set $DateTime ([:pick $gpsDateTime 0 $symPos]."-".[:pick $gpsDate
Time ($symPos + 1) [:len $gpsDateTime]])
:set $outputURL ("$serverURL?imei=$fakeImei&lat=$lat&lon=$lon&timestamp=$DateTime&hdop=$hdop&altitude=$alt&speed=$gpsSpeed&bearing=$bearing")

:if ($isDebug = "terminal") do={
:put $gpsDateTime
:put $DateTime
:put $lat
:put $lon
:put $alt
:put $gpsSpeed
:put $bearing
:put $gpsValid
:put $sats
:put $hdop
:put $serverURL
:put $fakeImei
:put $outputURL
}

:if ($isDebug = "logging") do={
:log info $gpsDateTime
:log info $DateTime
:log info $lat
:log info $lon
:log info $alt
:log info $gpsSpeed
:log info $bearing
:log info $gpsValid
:log info $sats
:log info $hdop
:log info $serverURL
:log info $fakeImei
:log info $outputURL
}

/tool fetch mode=http url="$outputURL" output=none


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Трекер на базе MikroTik LtAP
СообщениеДобавлено: 01 дек 2020, 16:19 
Не в сети

Зарегистрирован: 21 июн 2017, 15:27
Сообщений: 2
Какие переменные еще можно сюда отправлять? _http://livegpstracks.com/mikrotik.php
Обратную связь можно организовать, ответ на GET запрос, например передавать ответом произвольный текст скрипту от сервера?

Чуть меньше вариант.

[spoiler=Спойлер]
# GPS
:local fakeImei "12345678901234567890"
:local serverURL "http://livegpstracks.com/mikrotik.php"
:local outputURL
:local symPos
:local gpsDateTime
:global DateTime
:global lat
:global lon
:global alt
:global gpsSpeed
:global bearing
:global gpsValid
:global sats
:global hdop
:if ( [/system gps get coordinate-format ] != "dd") do={/system gps set coordinate-format=dd}
/system gps monitor once do={
:set $gpsDateTime $("date-and-time")
:set $lat [:pick $latitude 0 7]
:set $lon [:pick $longitude 0 8]
:set $alt $("altitude")
:set $gpsSpeed $("speed")
:set $bearing $("true-bearing")
:set $gpsValid $("valid")
:set $sats $("satellites")
:set $hdop $("horizontal-dilution") }
# Strip post comma value from speed, altitude and bearing
:set $alt [:pick $alt 0 [:find $alt "."]]
:set $gpsSpeed ([:pick $gpsSpeed 0 [:find $gpsSpeed "."]].".0")
:set $bearing ([:pick $bearing 0 [:find $bearing "."]].".0")
# Reformat Date-Time
:set $symPos [:find $gpsDateTime " "]
:set $DateTime ([:pick $gpsDateTime 0 $symPos]."-".[:pick $gpsDateTime ($symPos + 1) [:len $gpsDateTime]])
# GET
:set $outputURL ("$serverURL?imei=$fakeImei&lat=$lat&lon=$lon&timestamp=$DateTime&hdop=$hdop&altitude=$alt&speed=$gpsSpeed&bearing=$bearing")
/tool fetch mode=http url="$outputURL" output=none
# END
[/spoiler]


Вернуться наверх
 Профиль  
 
 Заголовок сообщения: Re: Трекер на базе MikroTik LtAP
СообщениеДобавлено: 03 янв 2021, 15:07 
Не в сети
Support Live GPS
Аватар пользователя

Зарегистрирован: 25 сен 2012, 08:43
Сообщений: 2706
a9b2 писал(а):
Какие переменные еще можно сюда отправлять? _http://livegpstracks.com/mikrotik.php

Чуть выше отвечали:
Вы весь список и перечислили.
Скрипт подключения реализовался в контакте с докладчиком. Больше пожеланий по параметрам не было, соответственно, только это и реализовано.


a9b2 писал(а):
Обратную связь можно организовать, ответ на GET запрос, например передавать ответом произвольный текст скрипту от сервера?

Нет, подобной возможности не предусмотрено и пока не планируется.


Вернуться наверх
 Профиль  
 
Показать сообщения за:  Сортировать по:  
Начать новую тему Ответить на тему  [ Сообщений: 8 ] 

Часовой пояс: UTC + 3 часа


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB

Поддержка: support@livegpstracks.com или форум Карта сайта © 2010-2020. Live GPS Tracking